www.ypnh.net > jQuEry在IE8下的错误"对象不支持此属性或方法"

jQuEry在IE8下的错误"对象不支持此属性或方法"

jquery2.0版本以上不再支持IE8以下,试下用jquery1.10

id为reg_domain_hidden的是什么标签,有text属性么?用val赋值试试呢

尽量用高版本!支持性 兼容性 都好些!

你可以在网页头部上加上兼容信息,让IE默认就按照兼容性视图的方式来显示你的网页,这样就不会有问题了,,具体方法你可以看考这里http://technet.microsoft.com/zh-cn/library/ff955640(WS.10).aspx

var kx_shipping = $("input[class=tradio]:checked").parent().next().text(); 声明的有问题吧 html()是替换ID为shipping元素下的html代码 而你kx_shipping声明出来的值只有在这个script闭合元素下才能执行 ID为shipping元素里面的值只能是html...

当然有不兼容的地方啊,但只是极少数地方,也要看看你的jquery包都是哪个版本的~ 建议用1.8.3版本最稳定,1.4.3也是个稳定版本。但用新不用旧还是1.8.3吧,2.0后都不支持IE 6 7 8了

没有以ie8为分割线的版本. jQuery 1.9及以下的版本支持IE的所有版本 1.9以上版本不再支持IE9以下版本

看起来象是你的main.js和jquery冲突了. 你先注释掉main.js,看还报不报这个错? 如果是冲突的话,那你下载jquery1.4看还冲突不? 如果与jquery1.4还冲突的话,那就得改你的main.js了.

jQuery下使用removeAttr时,在IE8以下版本中会出现属性移除不了的问题,现象是移除以后,仍然显示为disabled的状态,但文本框可录入,按钮可点击,严重的是,数据提交不了。 修正的方法是使用prop方法,如 $('#needDisabledElem').prop("disable...

jQuery从2.0版开始不再支持IE6、IE7和IE8. 请引用2.0以下的版本即可.

网站地图

All rights reserved Powered by www.ypnh.net

copyright ©right 2010-2021。
www.ypnh.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com